Alan Gates commented on HIVE-14950:

If you're going to create KW_INTEGER as a new keyword there are several places 
that KW_INT is referenced in IdentifiersParser.g that should also be updated.

I'm wondering if instead it makes more sense to change the definition of KW_INT 
in HiveLexer.g to be:
then you're guaranteed that they're interchangeable now and in the future.

> Support integer data type
> -------------------------
>                 Key: HIVE-14950
>                 URL: https://issues.apache.org/jira/browse/HIVE-14950
>             Project: Hive
>          Issue Type: Sub-task
>          Components: SQL
>            Reporter: Zoltan Haindrich
>            Assignee: Zoltan Haindrich
>            Priority: Minor
>         Attachments: HIVE-14950.1.patch
> maybe its just me bumping into this difference again and again...
> but it's in the sql2011 standard... 
> adding an alias for int would be easy.

This message was sent by Atlassian JIRA

Reply via email to