GitHub user JeonDaehong added a comment to the discussion: pyiceberg-core: 
python version limitation.

The `<3.13` cap was unintentional. It was introduced during the uv migration in 
#1796 and shipped with 0.8.0.

PR #2110 restored the `<4` upper bound because `pyiceberg-core` is built with 
PyO3's `abi3-py310`, which makes it forward-compatible with newer Python 3.x 
versions.

PyPI releases from 0.9.0 onward specify `requires-python = ">=3.10,<4"`, so 
upgrading to 0.9.0 or later is the recommended way to use Python 3.13 without 
forcing or bypassing the Python version constraint.

GitHub link: 
https://github.com/apache/iceberg-rust/discussions/2107#discussioncomment-18986873

----
This is an automatically sent email for [email protected].
To unsubscribe, please send an email to: [email protected]


---------------------------------------------------------------------
To unsubscribe, e-mail: [email protected]
For additional commands, e-mail: [email protected]

Reply via email to