Mirza Aliev created IGNITE-15656:
------------------------------------

             Summary: TODOs for refactor in raft module
                 Key: IGNITE-15656
                 URL: https://issues.apache.org/jira/browse/IGNITE-15656
             Project: Ignite
          Issue Type: Improvement
            Reporter: Mirza Aliev


There are several todos in raft module about code rafactoring, fields renaming 
and removing redundant code:

*  Refactor and remove duplicated code for 
{{org.apache.ignite.raft.jraft.core.CliServiceImpl#changePeers}}
* {{TODO}} in {{org.apache.ignite.raft.jraft.core.NodeImpl#fillLogEntryPeers}} 
method
* {{TODO}} in {{org.apache.ignite.raft.jraft.core.Replicator#sendEmptyEntries}}
* {{TODO IGNITE-14832 asch drop support for peer index}} in 
{{org.apache.ignite.raft.jraft.entity.PeerId#idx}} field
* Remove {{sharedElectionTimer}} and {{sharedVoteTimer}} in {{NodeOptions}} 
(see todos near the fields)
* Rename {{org.apache.ignite.raft.jraft.rpc.ClientService#connect}} to 
{{isAlive}
* Remove deprecated 
{{org.apache.ignite.raft.jraft.rpc.RpcClient#checkConnection}}
* Rename {{org.apache.ignite.raft.jraft.option.RpcOptions#rpcConnectTimeoutMs}} 
to handshake timeout
* Remove redundant {{sync}} flag in 
{{org.apache.ignite.raft.jraft.core.ReplicatorGroupImpl#addReplicator}}
* Rename 
{{org.apache.ignite.raft.jraft.rpc.impl.ConnectionClosedEventListener}} to 
nodeleftlistener
* 



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

Reply via email to