[ 
https://issues.apache.org/jira/browse/IGNITE-17999?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Vladislav Pyatkov updated IGNITE-17999:
---------------------------------------
    Description: 
*Motivation:*
After observation, the following points were highlighting to fix:
# The request has a property named is commitTimestamp, but it is not a time to 
commit. This property should be renamed to readTimestamp, because it is a time 
with which a transaction tries to read another transaction state (to read an 
entry).
# The request should to be handled by a primary replica (presently, it is 
handled by leader, that can be a different node).
# TxMata should be read through RAFT, because the leader can be changed, and 
the actual data will be store on the new one.

*Definition of done:*
# Property {{TxStateReplicaRequest#commitTimestamp}} should change to 
{{TxStateReplicaRequest#readTimestamp}}.
# Because {{TxStateReplicaRequest}} is sent from {{PlacementDriver}}, there is 
no a reference to the raft client, the sending will be happening to the node 
from an assignment. It {{PrimaryReplicaMissException}} will be caught, the 
request should be resent to next node from the assignment.
# We can use a specific read command for read through RAFT. The same command 
had been already written before and removed after. Need to resurrect the 
command or write similar yourselves.

  was:
*Motivation:*
After observation, the following points were highlighting to fix:
# The request has a property named is commitTimestamp, but it is not a time to 
commit. This property should be renamed to readTimestamp, because it is a time 
with which a transaction tries to read another transaction state (to read an 
entry).
# The request should to be handled by a primary replica (presently, it is 
handled by leader, that can be a different node).
# TxMata should be read through RAFT, because the leader can be changed, and 
the actual data will be store on the new one.

*Definition of done:*
# Property {{TxStateReplicaRequest#commitTimestamp}} should change to 
{{TxStateReplicaRequest#readTimestamp}}.
# Because {{TxStateReplicaRequest}} is sent from PlacementDriver, there is no a 
reference to the raft client, the sending will be happening to the node from an 
assignment. It PrimaryReplicaMissException will be caught, the request should 
be resent to next node from the assignment.
# We can use a specific read command for read through RAFT. The same command 
had been already written before and removed after. Need to resurrect the 
command or write similar yourselves.


> Incorrect handling of TxStateReplicaRequest
> -------------------------------------------
>
>                 Key: IGNITE-17999
>                 URL: https://issues.apache.org/jira/browse/IGNITE-17999
>             Project: Ignite
>          Issue Type: Bug
>            Reporter: Vladislav Pyatkov
>            Priority: Major
>              Labels: ignite-3
>
> *Motivation:*
> After observation, the following points were highlighting to fix:
> # The request has a property named is commitTimestamp, but it is not a time 
> to commit. This property should be renamed to readTimestamp, because it is a 
> time with which a transaction tries to read another transaction state (to 
> read an entry).
> # The request should to be handled by a primary replica (presently, it is 
> handled by leader, that can be a different node).
> # TxMata should be read through RAFT, because the leader can be changed, and 
> the actual data will be store on the new one.
> *Definition of done:*
> # Property {{TxStateReplicaRequest#commitTimestamp}} should change to 
> {{TxStateReplicaRequest#readTimestamp}}.
> # Because {{TxStateReplicaRequest}} is sent from {{PlacementDriver}}, there 
> is no a reference to the raft client, the sending will be happening to the 
> node from an assignment. It {{PrimaryReplicaMissException}} will be caught, 
> the request should be resent to next node from the assignment.
> # We can use a specific read command for read through RAFT. The same command 
> had been already written before and removed after. Need to resurrect the 
> command or write similar yourselves.



--
This message was sent by Atlassian Jira
(v8.20.10#820010)

Reply via email to