[
https://issues.apache.org/jira/browse/IGNITE-22272?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]
Vadim Kolodin updated IGNITE-22272:
-----------------------------------
Description:
* Do not return a Query that has to be executed, run it immediately. For
example: *Table table = catalog.createTable(Pojo.class)*
* All methods should be async-first
* Rename *create* to *createTable* (recordClass and KV methods)
* all *createTable* methods should return a {*}Table{*}. Especially important
for record and KV cases, where the resulting name is not obvious
* add option to specify column/index order in builders, annotations - explicit
order or implicit "default" (in case of composite index, colocation columns)
was:
* Do not return a Query that has to be executed, run it immediately. For
example: *Table table = catalog.createTable(Pojo.class)*
* All methods should be async-first
* Rename *create* to *createTable* (recordClass and KV methods)
* all *createTable* methods should return a {*}Table{*}. Especially important
for record and KV cases, where the resulting name is not obvious
* add option to specify column/index order in builders, annotations (in case
of composite index, colocation columns)
> Rework Catalog API
> ------------------
>
> Key: IGNITE-22272
> URL: https://issues.apache.org/jira/browse/IGNITE-22272
> Project: Ignite
> Issue Type: Improvement
> Components: sql
> Reporter: Pavel Tupitsyn
> Priority: Critical
> Labels: ignite-3
> Fix For: 3.0.0-beta2
>
>
> * Do not return a Query that has to be executed, run it immediately. For
> example: *Table table = catalog.createTable(Pojo.class)*
> * All methods should be async-first
> * Rename *create* to *createTable* (recordClass and KV methods)
> * all *createTable* methods should return a {*}Table{*}. Especially
> important for record and KV cases, where the resulting name is not obvious
> * add option to specify column/index order in builders, annotations -
> explicit order or implicit "default" (in case of composite index, colocation
> columns)
--
This message was sent by Atlassian Jira
(v8.20.10#820010)