Pavel Tupitsyn created IGNITE-22429:
---------------------------------------

             Summary: JobStatus builder should be private
                 Key: IGNITE-22429
                 URL: https://issues.apache.org/jira/browse/IGNITE-22429
             Project: Ignite
          Issue Type: Improvement
          Components: compute
    Affects Versions: 3.0.0-beta1
            Reporter: Pavel Tupitsyn
            Assignee: Pavel Tupitsyn
             Fix For: 3.0.0-beta2


Currently, *JobExecutionContext.isInterrupted* is set to true when the job is 
cancelled. This flag exists so that any job-related thread can perform 
cooperative cancellation (as opposed to relying on thread interrupted status).

Therefore, *isCancelled* is a better name. Improve javadoc accordingly.



--
This message was sent by Atlassian Jira
(v8.20.10#820010)

Reply via email to