[ 
https://issues.apache.org/jira/browse/IGNITE-4481?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15867689#comment-15867689
 ] 

Ilya Suntsov edited comment on IGNITE-4481 at 2/16/17 9:19 AM:
---------------------------------------------------------------

[~oleg-ostanin]

I've reviewed your changes in {{benchmark-run-all.sh}}. Here is my comments:
1. Please use {{$(smth)}} instead of {{`smth`}}. It's appears here:  
{noformat}MAIN_DIR=`cd ${SCRIPT_DIR}/../; pwd`{noformat}

2. I got file {{gc132604.log}} in {{MAIN_DIR}} after run 3 benchmarks on 
localhost. All benchmarks from one properties file (default configuration - 
benchmark.properties)

3. Need to add actual help for {{benchmark-run-all.sh}}. Now when I'm typing 
{{benchmark-run-all.sh -h}} it shows only:
{noformat}
Usage: benchmark-run-all.sh [PROPERTIES_FILE_PATH]
Script that executes BenchmarkDriver locally and BenchmarkServers on remote 
machines.
{noformat}

4. Please change here separator. It is space, not comma. {noformat}IFS=',' read 
-ra local_ips_array <<< ${local_ip_addresses[@]}{noformat}

5. You are using {{uniq_ips}} array as global variable. I think it would be 
better to return this array from function {{define_ips}} as string and then  in 
{{copy_to_hosts}} and {{collect_results}} split it by whitespace. Please look 
here: http://www.linuxjournal.com/content/return-values-bash-functions

6. In function  {{copy_to_hosts}} need to add {{else}} part when something 
happens if {{MAIN_DIR}} already exist on remote host

7. Please change name of variable {{folder}} to {{results_folder}} 

8. Please remove this condition {{$ip != $local_ip_addr}} from function 
{{collect_results}} 

9. Please replace {noformat}if echo "${DRIVER_HOSTS}" | grep -i $ip 
>/dev/null{noformat} to {noformat}if [[ ${DRIVER_HOSTS}== *"$ip"* ]]{noformat}



was (Author: ustas):
[~oleg-ostanin]

I've reviewed your changes in {{benchmark-run-all.sh}}. Here is my comments:
1. Please use {{$(smth)}} instead of {{`smth`}}. It's appears here:  
{noformat}MAIN_DIR=`cd ${SCRIPT_DIR}/../; pwd`{noformat}

2. I got file {{gc132604.log}} in {{MAIN_DIR}} after run 3 benchmarks on 
localhost. All benchmarks from one properties file (default configuration - 
benchmark.properties)

3. Need to add actual help for {{benchmark-run-all.sh}}. Now when I'm typing 
{{benchmark-run-all.sh -h}} it shows only:
{noformat}
Usage: benchmark-run-all.sh [PROPERTIES_FILE_PATH]
Script that executes BenchmarkDriver locally and BenchmarkServers on remote 
machines.
{noformat}

4. Please change here separator. It is space, not comma. {noformat}IFS=',' read 
-ra local_ips_array <<< ${local_ip_addresses[@]}{noformat}

5. You are using {{uniq_ips}} array as global variable. I think it would be 
better to return this array from function {{define_ips}} as string and then  in 
{{ copy_to_hosts }} and {{collect_results}} split it by whitespace. Please look 
here: http://www.linuxjournal.com/content/return-values-bash-functions

6. In function  {{copy_to_hosts}} need to add {{else}} part when something 
happens if {{MAIN_DIR}} already exist on remote host

7. Please change name of variable {{folder}} to {{results_folder}} 

8. Please remove this condition {{$ip != $local_ip_addr}} from function 
{{collect_results}} 

9. Please replace {noformat}if echo "${DRIVER_HOSTS}" | grep -i $ip 
>/dev/null{noformat} to {noformat}if [[ ${DRIVER_HOSTS}== *"$ip"* ]]{noformat}


> Creating the scripts
> --------------------
>
>                 Key: IGNITE-4481
>                 URL: https://issues.apache.org/jira/browse/IGNITE-4481
>             Project: Ignite
>          Issue Type: Sub-task
>            Reporter: Oleg Ostanin
>            Assignee: Oleg Ostanin
>             Fix For: 2.0
>
>
> The goal of this subtask is to resolve this part of original task:
> 1. Every deliverable must contain an executable (bat or sh file) with a clear 
> instruction on how to start a specific benchmark from the console.
> 2. For local runs (drivers and servers point out on localhost) ssh connection 
> must not be used



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Reply via email to