[ 
https://issues.apache.org/jira/browse/IGNITE-5794?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16116201#comment-16116201
 ] 

Sergey Chugunov commented on IGNITE-5794:
-----------------------------------------

More specific detail: after reconnect client still has binary metadata about 
custom type in BinaryContext::descByClass collection.
So to fix the root cause problem descriptors for custom types must be cleaned 
up from it, however it must be extensively tested to be sure that such a change 
won't break anything else.

> BinaryMetadata is lost if all server nodes have been restarted
> --------------------------------------------------------------
>
>                 Key: IGNITE-5794
>                 URL: https://issues.apache.org/jira/browse/IGNITE-5794
>             Project: Ignite
>          Issue Type: Bug
>          Components: binary, general
>    Affects Versions: 2.1
>            Reporter: Ilya Lantukh
>
> Steps to reproduce are described here: 
> http://apache-ignite-users.70518.x6.nabble.com/Problem-with-Messages-after-client-reconnect-td15127.html#none
> This problem occurs because client has metadata in it's local metadata cache 
> and decides that server node should have it too. But server lost it after 
> restart.
> Possible fixes:
> - Make client nodes re-send all contents of local metadata cache after 
> reconnect.
> - If node doesn't have metadata to process incoming message, it should 
> request it from sender node.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Reply via email to