[ 
https://issues.apache.org/jira/browse/IGNITE-5736?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16121448#comment-16121448
 ] 

Vyacheslav Daradur commented on IGNITE-5736:
--------------------------------------------

[PR-2425|https://github.com/apache/ignite/pull/2425] contains changes of 3 
tasks:
IGNITE-5732 Provide API to test compatibility with old releases
IGNITE-5097 BinaryMarshaller should write ints in "varint" encoding where it 
makes sense (parent issue)
IGNITE-5736 Add test of backward-compatibility (current issue)

[Upsource review 
created.|https://reviews.ignite.apache.org/ignite/review/IGNT-CR-274]

[Upsource link to VarintArraysSizeCompatibilityTest 
only.|https://reviews.ignite.apache.org/ignite/review/IGNT-CR-274?filePath=/modules/compatibility/src/test/java/org/apache/ignite/compatibility/binary/VarintArraysSizeCompatibilityTest.java]

> Add test of backward-compatibility
> ----------------------------------
>
>                 Key: IGNITE-5736
>                 URL: https://issues.apache.org/jira/browse/IGNITE-5736
>             Project: Ignite
>          Issue Type: Sub-task
>          Components: general
>            Reporter: Vyacheslav Daradur
>            Assignee: Vyacheslav Daradur
>             Fix For: 2.2
>
>
> Need to add unit-test to test compatibility with AI 2.0.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Reply via email to