Roman Kondakov created IGNITE-7501:
--------------------------------------

             Summary: Improve underlying iterators closing process for cache 
iterators.
                 Key: IGNITE-7501
                 URL: https://issues.apache.org/jira/browse/IGNITE-7501
             Project: Ignite
          Issue Type: Improvement
          Components: cache
    Affects Versions: 2.3
            Reporter: Roman Kondakov
             Fix For: 2.5


When we call {{javax.cache.Cache#iterator()}}  we get {{java.util.Iterator}} 
which doesn't have a {{close()}} method. But underlying 
{{GridCloseableIterator}} does have this method and it should be called when 
all the work with the current iterator is done. Currently calling {{close()}} 
for the underlying closeable iterator is delegated to 
{{WeakQueryCloseableIterator}}. So, {{close()}} method is usually called on a 
garbage collection phase, which is not acceptable in some situations. For 
example if MVCC is enabled this *late* iterator closing could dramatically 
increase the active queries tracking list size which  could lead to the 
performance and garbage collection ("vacuum") issues.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Reply via email to