[ 
https://issues.apache.org/jira/browse/IGNITE-8149?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16597429#comment-16597429
 ] 

Igor Seliverstov commented on IGNITE-8149:
------------------------------------------

[~Pavlukhin], see my comments below:
1) Move {{applyAndCollectLocalUpdateCounters()}} and 
{{txCounters().updateCounters(updCntrs)}} to 
{{org.apache.ignite.internal.processors.cache.transactions.IgniteTxLocalAdapter#applyTxCounters}}
2) Inline 
{{org.apache.ignite.internal.processors.cache.distributed.GridDistributedTxRemoteAdapter#applyUpdateCounters}}
 method
3) Inline 
{{org.apache.ignite.internal.processors.cache.transactions.IgniteTxAdapter#applyCacheSizeDeltas}}
 method
4) 
{{org.apache.ignite.internal.processors.cache.transactions.IgniteTxLocalState#updatedCachePartitions}}
 - involvedPartitions, I think, much better name
5) 
{{org.apache.ignite.internal.processors.cache.transactions.IgniteTxLocalStateAdapter#updCacheParts}}
 has no sense for non-mvcc transactions and should be initialized lazily
6) What about changes, made by DataStreamer? Appropriate tests are needed.
7) There are no tests for size consistency after just joined node is fully 
rebalanced.
8) Inline 
{{org.apache.ignite.internal.processors.cache.IgniteCacheOffheapManagerImpl.CacheDataStoreImpl#updateSize0}}
 and use 
{{org.apache.ignite.internal.processors.cache.IgniteCacheOffheapManagerImpl.CacheDataStoreImpl#updateSize}}
 instead
9) Check imports.

> MVCC TX: Size method should use tx snapshot
> -------------------------------------------
>
>                 Key: IGNITE-8149
>                 URL: https://issues.apache.org/jira/browse/IGNITE-8149
>             Project: Ignite
>          Issue Type: Task
>          Components: cache, mvcc
>            Reporter: Igor Seliverstov
>            Assignee: Ivan Pavlukhin
>            Priority: Major
>             Fix For: 2.7
>
>
> Currently cache.size() returns number of entries in cache trees while there 
> can be several versions of one key-value pairs.
> We should use tx snapshot and count all passed mvcc filter entries instead.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Reply via email to