Fredy Wijaya created IMPALA-6862:
------------------------------------

             Summary: Privilege.java needs to support Sentry 1.5.1 and Sentry 
2.0.0 API
                 Key: IMPALA-6862
                 URL: https://issues.apache.org/jira/browse/IMPALA-6862
             Project: IMPALA
          Issue Type: Bug
          Components: Frontend
            Reporter: Fredy Wijaya
            Assignee: Fredy Wijaya


In Sentry 1.5.1, BitFieldAction is an abstract class: 
[https://github.com/apache/sentry/blob/release-1.5.1/sentry-core/sentry-core-common/src/main/java/org/apache/sentry/core/common/BitFieldAction.java#L22].
 Sentry removed the abstract requirement in Sentry 2.0.0: 
[https://github.com/apache/sentry/blob/master/sentry-core/sentry-core-common/src/main/java/org/apache/sentry/core/common/BitFieldAction.java#L23]



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Reply via email to