[
https://issues.apache.org/jira/browse/KARAF-4707?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15493335#comment-15493335
]
Oliver Lietz commented on KARAF-4707:
-------------------------------------
Additionally, we should rename the {{wrap}} feature to {{pax-url-wrap}} and
make {{wrap}} an _alias_ and deprecate.
> Add pax-url-classpath feature
> -----------------------------
>
> Key: KARAF-4707
> URL: https://issues.apache.org/jira/browse/KARAF-4707
> Project: Karaf
> Issue Type: Improvement
> Components: karaf-feature
> Reporter: Alex Soto
> Assignee: Jean-Baptiste Onofré
> Fix For: 4.1.0, 4.0.7
>
>
> To make it easier to use class path URLs. Something like.
> {code:xml}
> <feature name="pax-url-handler">
> <bundle>mvn:org.ops4j.base/ops4j-base-util-property/1.5.0</bundle>
> <bundle>mvn:org.ops4j.base/ops4j-base-lang/1.5.0</bundle>
> <bundle>mvn:org.ops4j.pax.swissbox/pax-swissbox-property/1.8.2</bundle>
> <bundle>mvn:org.ops4j.pax.url/pax-url-commons/2.4.7</bundle>
> <bundle>mvn:org.ops4j.pax.url/pax-url-classpath/2.4.7</bundle>
> </feature>
> {code}
> Also, it would be nice to have documentation about how to use it for
> deploying config files in features.xml:
> {code:xml}
> <configfile finalname="${karaf.etc}/my.config.cfg">
> classpath:my.config.cfg
> </configfile>
> {code}
--
This message was sent by Atlassian JIRA
(v6.3.4#6332)