[ 
https://issues.apache.org/jira/browse/KARAF-4360?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Jean-Baptiste Onofré updated KARAF-4360:
----------------------------------------
    Fix Version/s:     (was: 4.0.7)
                   4.0.8

> FrameworkEvent ERROR in the karaf.log when install cxf-core feature
> -------------------------------------------------------------------
>
>                 Key: KARAF-4360
>                 URL: https://issues.apache.org/jira/browse/KARAF-4360
>             Project: Karaf
>          Issue Type: Bug
>          Components: karaf-feature
>    Affects Versions: 4.0.4
>         Environment: Java 8
>            Reporter: Xilai Dai
>            Assignee: Jean-Baptiste Onofré
>            Priority: Minor
>             Fix For: 4.1.0, 4.0.8
>
>
> When trying to install cxf-core feature into Karaf 4.0.4, there is 
> FrameworkEvent ERROR in the karaf.log, but the bundles can be started and in 
> the Active status.
> {code}
> 2016-02-25 12:09:57,529 | ERROR | 8d8-961af9b70a25 | cxf-core                 
>         | 53 - org.apache.cxf.cxf-core - 3.1.5 | FrameworkEvent ERROR - 
> org.apache.cxf.cxf-core
> org.osgi.framework.BundleException: Could not resolve module: 
> org.apache.cxf.cxf-core [53]
>   Unresolved requirement: Import-Package: com.ctc.wstx.msv; 
> version="[4.4.0,5.0.0)"; resolution:="optional"
>   Unresolved requirement: Import-Package: com.ctc.wstx.stax; 
> version="[4.4.0,5.0.0)"; resolution:="optional"
>   Unresolved requirement: Import-Package: org.codehaus.stax2; 
> version="[3.1.0,4.0.0)"; resolution:="optional"
>   Unresolved requirement: Import-Package: org.codehaus.stax2.validation; 
> version="[3.1.0,4.0.0)"; resolution:="optional"
>   Unresolved requirement: Import-Package: com.sun.msv.grammar; 
> version="[2013.6.0,2014.0.0)"; resolution:="optional"
>   Unresolved requirement: Import-Package: com.sun.msv.grammar.xmlschema; 
> version="[2013.6.0,2014.0.0)"; resolution:="optional"
>   Unresolved requirement: Import-Package: com.sun.msv.reader; 
> version="[2013.6.0,2014.0.0)"; resolution:="optional"
>   Unresolved requirement: Import-Package: com.sun.msv.reader.xmlschema; 
> version="[2013.6.0,2014.0.0)"; resolution:="optional"
>   Unresolved requirement: Import-Package: com.sun.xml.bind.marshaller; 
> version="[2.2.0,3.0.0)"; resolution:="optional"
>   Unresolved requirement: Import-Package: com.sun.xml.fastinfoset.stax; 
> version="[1.2.0,2.0.0)"; resolution:="optional"
>   Unresolved requirement: Import-Package: net.sf.cglib.proxy; 
> version="[2.1.3,3.0.0)"; resolution:="optional"
>   Unresolved requirement: Import-Package: org.springframework.osgi.io; 
> version="[1.2.0,2.0.0)"; resolution:="optional"
>   Unresolved requirement: Import-Package: org.springframework.osgi.util; 
> version="[1.2.0,2.0.0)"; resolution:="optional"
>   Unresolved requirement: Import-Package: org.springframework.aop; 
> version="[3.1.0,5.0.0)"; resolution:="optional"
>   Unresolved requirement: Import-Package: org.springframework.aop.framework; 
> version="[3.1.0,5.0.0)"; resolution:="optional"
>   Unresolved requirement: Import-Package: org.springframework.aop.support; 
> version="[3.1.0,5.0.0)"; resolution:="optional"
>   Unresolved requirement: Import-Package: org.springframework.beans; 
> version="[3.1.0,5.0.0)"; resolution:="optional"
>   Unresolved requirement: Import-Package: org.springframework.beans.factory; 
> version="[3.1.0,5.0.0)"; resolution:="optional"
>   Unresolved requirement: Import-Package: 
> org.springframework.beans.factory.config; version="[3.1.0,5.0.0)"; 
> resolution:="optional"
>   Unresolved requirement: Import-Package: 
> org.springframework.beans.factory.support; version="[3.1.0,5.0.0)"; 
> resolution:="optional"
>   Unresolved requirement: Import-Package: 
> org.springframework.beans.factory.wiring; version="[3.1.0,5.0.0)"; 
> resolution:="optional"
>   Unresolved requirement: Import-Package: 
> org.springframework.beans.factory.xml; version="[3.1.0,5.0.0)"; 
> resolution:="optional"
>   Unresolved requirement: Import-Package: org.springframework.context; 
> version="[3.1.0,5.0.0)"; resolution:="optional"
>   Unresolved requirement: Import-Package: org.springframework.context.event; 
> version="[3.1.0,5.0.0)"; resolution:="optional"
>   Unresolved requirement: Import-Package: 
> org.springframework.context.support; version="[3.1.0,5.0.0)"; 
> resolution:="optional"
>   Unresolved requirement: Import-Package: org.springframework.core; 
> version="[3.1.0,5.0.0)"; resolution:="optional"
>   Unresolved requirement: Import-Package: org.springframework.core.io; 
> version="[3.1.0,5.0.0)"; resolution:="optional"
>   Unresolved requirement: Import-Package: 
> org.springframework.core.io.support; version="[3.1.0,5.0.0)"; 
> resolution:="optional"
>   Unresolved requirement: Import-Package: org.springframework.core.type; 
> version="[3.1.0,5.0.0)"; resolution:="optional"
>   Unresolved requirement: Import-Package: 
> org.springframework.core.type.classreading; version="[3.1.0,5.0.0)"; 
> resolution:="optional"
>   Unresolved requirement: Import-Package: org.springframework.util; 
> version="[3.1.0,5.0.0)"; resolution:="optional"
>   Unresolved requirement: Import-Package: javax.validation; 
> version="[1.0.0,2.0.0)"; resolution:="optional"
>   Unresolved requirement: Import-Package: javax.validation.bootstrap; 
> version="[1.0.0,2.0.0)"; resolution:="optional"
>   Unresolved requirement: Import-Package: javax.validation.executable; 
> version="[1.0.0,2.0.0)"; resolution:="optional"
>   Unresolved requirement: Import-Package: javax.validation.spi; 
> version="[1.0.0,2.0.0)"; resolution:="optional"
>   Unresolved requirement: Import-Package: org.apache.ws.commons.schema; 
> version="[2.2.0,3.0.0)"
>   Unresolved requirement: Import-Package: javax.annotation; 
> version="[0.0.0,2.0.0)"
>     -> Export-Package: javax.annotation; 
> bundle-symbolic-name="javax.annotation-api"; bundle-version="1.2.0"; 
> version="1.2.0"
>        javax.annotation-api [52]
>       at 
> org.eclipse.osgi.container.Module.start(Module.java:434)[org.eclipse.osgi-3.10.2.v20150203-1939.jar:]
>       at 
> org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1498)[org.eclipse.osgi-3.10.2.v20150203-1939.jar:]
>       at 
> org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)[org.eclipse.osgi-3.10.2.v20150203-1939.jar:]
>       at 
> org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)[org.eclipse.osgi-3.10.2.v20150203-1939.jar:]
>       at 
> org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)[org.eclipse.osgi-3.10.2.v20150203-1939.jar:]
> {code}
> Reproduce steps:
> set karaf.framework=equinox in the etc/config.properties, start karaf and run:
> repo-add cxf 3.1.5
> feature:install cxf-core
> With karaf 4.0.3, there is no this kind of ERROR in the karaf.log, but some 
> bundles stay in the Starting status.
> {code}
> 53 | Starting |  40 | 3.1.5                 | Apache CXF Core
> 54 | Starting |  40 | 3.1.5                 | Apache CXF Runtime Management
> {code}



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Reply via email to