[ 
https://issues.apache.org/jira/browse/KARAF-4847?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15712980#comment-15712980
 ] 

Lijun Liao commented on KARAF-4847:
-----------------------------------

The fix works. I can start the pax-jetty feature.

> Cannot start feature pax-jetty with JDK 9
> -----------------------------------------
>
>                 Key: KARAF-4847
>                 URL: https://issues.apache.org/jira/browse/KARAF-4847
>             Project: Karaf
>          Issue Type: Bug
>          Components: karaf-feature
>    Affects Versions: 4.1.0
>         Environment: Ubuntu
> JDK Early Access Releases 9 Build 146
>            Reporter: Lijun Liao
>            Assignee: Guillaume Nodet
>            Priority: Critical
>              Labels: java9
>             Fix For: 4.1.0
>
>         Attachments: karaf.log
>
>
> Steps to reproduce the error:
> 1. Start a terminal
> 2. Start karaf (bin/karaf)
> 3. Install feature pax-jetty (feature:install pax-jetty)
> Karaf shows the following message immediately
> {code}
> karaf@root()> feature:install pax-jetty                   xx:xx:xx
> Error executing command: java.lang.InterruptedException
> gogo: InterruptedException: null
> {code}
> After a while or being cancelled by CTRL + C, karaf ends up.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Reply via email to