[ 
https://issues.apache.org/jira/browse/KARAF-5111?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Jean-Baptiste Onofré updated KARAF-5111:
----------------------------------------
    Description: 
I am trying to install a feature i wrote to install iPojo.  I can manually 
install the two bundles, but when i install the "feature" that does the same 
thing it give me the following error:

{code}
Error executing command: java.lang.InterruptedException
{code}

I've attached the karaf.log as well.  ${version.ipojo} = 1.12.1

The feature is simple:

{code}
    <feature name="ipojo" version="${version.ipojo}">
        
<bundle>mvn:org.apache.felix/org.apache.felix.ipojo/${version.ipojo}</bundle>
        
<bundle>mvn:org.apache.felix/org.apache.felix.ipojo.api/${version.ipojo}</bundle>
    </feature>
{code}

  was:
I am trying to install a feature i wrote to install iPojo.  I can manually 
install the two bundles, but when i install the "feature" that does the same 
thing it give me the following error:
Error executing command: java.lang.InterruptedException

I've attached the karaf.log as well.  ${version.ipojo} = 1.12.1

The feature is simple:

    <feature name="ipojo" version="${version.ipojo}">
        
<bundle>mvn:org.apache.felix/org.apache.felix.ipojo/${version.ipojo}</bundle>
        
<bundle>mvn:org.apache.felix/org.apache.felix.ipojo.api/${version.ipojo}</bundle>
    </feature>



> Error executing command: java.lang.InterruptedException when installing 
> feature
> -------------------------------------------------------------------------------
>
>                 Key: KARAF-5111
>                 URL: https://issues.apache.org/jira/browse/KARAF-5111
>             Project: Karaf
>          Issue Type: Bug
>          Components: karaf-feature
>    Affects Versions: 4.1.1
>         Environment: JDK 8, MacOS
>            Reporter: Andy Phillips
>            Assignee: Jean-Baptiste Onofré
>             Fix For: 4.2.0, 4.1.2
>
>         Attachments: karaf.log
>
>
> I am trying to install a feature i wrote to install iPojo.  I can manually 
> install the two bundles, but when i install the "feature" that does the same 
> thing it give me the following error:
> {code}
> Error executing command: java.lang.InterruptedException
> {code}
> I've attached the karaf.log as well.  ${version.ipojo} = 1.12.1
> The feature is simple:
> {code}
>     <feature name="ipojo" version="${version.ipojo}">
>         
> <bundle>mvn:org.apache.felix/org.apache.felix.ipojo/${version.ipojo}</bundle>
>         
> <bundle>mvn:org.apache.felix/org.apache.felix.ipojo.api/${version.ipojo}</bundle>
>     </feature>
> {code}



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Reply via email to