[ 
https://issues.apache.org/jira/browse/KARAF-5110?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Jean-Baptiste Onofré updated KARAF-5110:
----------------------------------------
    Fix Version/s: 4.1.2
                   4.2.0

> Karaf 4.1.x / httplite incompatibility
> --------------------------------------
>
>                 Key: KARAF-5110
>                 URL: https://issues.apache.org/jira/browse/KARAF-5110
>             Project: Karaf
>          Issue Type: Bug
>    Affects Versions: 4.1.1
>         Environment: Maven 3.3.9 / MacOS 10.12.4
>            Reporter: Stephen Winnall
>            Assignee: Jean-Baptiste Onofré
>             Fix For: 4.2.0, 4.1.2
>
>         Attachments: karaf-4.1.x-httplite.tbz
>
>
> I am trying to build a Karaf assembly using Karaf 4.1.1, Java 
> 1.8.0_76-ea-b04, Maven 3.3.9, Netbeans 8.2 and macOS 10.12.4. I am getting an 
> error message, even if I omit all my own features from the build (i.e. I 
> build an empty Karaf): 
>     java.lang.ClassCastException: 
> org.apache.felix.httplite.osgi.HttpServiceImpl cannot be cast to 
> org.osgi.service.http.HttpService 
> The problem seems to be that the latest version of 
> org.apache.felix.httplite.complete, which provides 
> org.apache.felix.httplite.osgi.HttpServiceImpl, i.e. 0.1.5, requires a 
> version of java.servlet that is incompatible with the rest of Karaf 4.1.1, 
> which - I think - expects 3.1.0. The following comes from the MANIFEST.MF of 
> org.apache.felix.httplite.complete-0.1.5.jar: 
>     Import-Package: javax.servlet;version="[2.4,3)" 



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Reply via email to