Grzegorz Grzybek created KARAF-5593:
---------------------------------------

             Summary: karaf-assembly-plugin / builder could include only 
highest version number of dependent feature
                 Key: KARAF-5593
                 URL: https://issues.apache.org/jira/browse/KARAF-5593
             Project: Karaf
          Issue Type: Improvement
          Components: karaf-tooling
            Reporter: Grzegorz Grzybek
            Assignee: Grzegorz Grzybek


When there's karaf-maven-plugin:assembly configuration:
{code:xml}
<installedFeatures>
...
    <feature>camel-spring</feature>
...
</installedFeatures>
{code}

The distro being assembled contains 3 versions of Spring dependencies: 4.1.x, 
4.2.x and 4.3.x, because camel-spring depends on:
{code:xml}
<feature version='[4.1,5)'>spring</feature>
<feature version='[4.1,5)'>spring-tx</feature>
{code}

Maybe it'd be good to configure AssemblyMojo → Builder → 
org.apache.karaf.profile.assembly.FeatureSelector to pick up only one version?



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Reply via email to