Greg created KUDU-1706:
--------------------------

             Summary: Unable to build from source using Python 3
                 Key: KUDU-1706
                 URL: https://issues.apache.org/jira/browse/KUDU-1706
             Project: Kudu
          Issue Type: Improvement
          Components: build
    Affects Versions: 1.0.1
         Environment: uname -a: Linux desktop 4.4.0-43-generic #63-Ubuntu SMP 
Wed Oct 12 13:48:03 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux
python 3 installed by default
            Reporter: Greg


Building from source using results in Python print Syntax error.

Running this script:
```
#!/bin/bash

sudo apt-get -y install git autoconf automake \
  curl gcc g++ libsasl2-dev libsasl2-modules \
  libtool ntp patch pkg-config make rsync unzip vim-common gdb python 
lsb-release
git clone https://github.com/apache/kudu
cd kudu
thirdparty/build-if-necessary.sh
mkdir -p build/release
cd build/release
../../thirdparty/installed/bin/cmake \
  -DCMAKE_BUILD_TYPE=release \
  ../..
make -j4
```

Results in:
```
++ BOOST_VERSION=1_61_0
++ BOOST_NAME=boost_1_61_0
++ BOOST_SOURCE=/home/greg/kudu/thirdparty/src/boost_1_61_0
+ source /home/greg/kudu/thirdparty/build-definitions.sh
+ /home/greg/kudu/thirdparty/preflight.py
  File "/home/greg/kudu/thirdparty/preflight.py", line 84
    print(>>p.stdin, script)
           ^
SyntaxError: invalid syntax
kudu.sh: line 12: ../../thirdparty/installed/bin/cmake: No such file or 
directory
make: *** No targets specified and no makefile found.  Stop.
```



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Reply via email to