[ 
https://issues.apache.org/jira/browse/KUDU-2092?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16119051#comment-16119051
 ] 

Todd Lipcon commented on KUDU-2092:
-----------------------------------

Did you mean to say "dynamically link against kerberos"? and "unable to build 
on" rather than "unable to run on"?

> Pull in krb5_is_config_principal() when running against older kerberos 
> versions
> -------------------------------------------------------------------------------
>
>                 Key: KUDU-2092
>                 URL: https://issues.apache.org/jira/browse/KUDU-2092
>             Project: Kudu
>          Issue Type: Improvement
>          Components: security
>    Affects Versions: 1.4.0
>            Reporter: Sailesh Mukil
>            Assignee: Sailesh Mukil
>
> On kerberos versions < krb5-1.8, the function krb5_is_config_principal() does 
> not exist. Since our code uses that function, and we statically link against 
> kerberos, we would be unable to run on systems that have these old kerberos 
> versions.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Reply via email to