[ 
https://issues.apache.org/jira/browse/KYLIN-3250?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Ted Yu updated KYLIN-3250:
--------------------------
    Description: 
Currently Kylin depends on 9.2.20.v20161216 which is quite old.

Memory leak was fixed in Jetty 9.4 and later backported however the version of 
Jetty 9.2.20 came before this fix.  See 
[https://github.com/eclipse/jetty.project/issues/1804] and 
[https://github.com/apache/hbase/blob/master/pom.xml#L1416.]

This issue is to upgrade to 
[9.3.22.v20171030|https://mvnrepository.com/artifact/org.eclipse.jetty/jetty-server/9.3.22.v20171030]
 which is the latest version of 9.3

  was:
Currently Kylin depends on 9.2.20.v20161216 which is quite old.

This issue is to upgrade to 9.2.24.v20180105


> Upgrade jetty version to 9.2.24.v20180105
> -----------------------------------------
>
>                 Key: KYLIN-3250
>                 URL: https://issues.apache.org/jira/browse/KYLIN-3250
>             Project: Kylin
>          Issue Type: Improvement
>            Reporter: Ted Yu
>            Priority: Minor
>
> Currently Kylin depends on 9.2.20.v20161216 which is quite old.
> Memory leak was fixed in Jetty 9.4 and later backported however the version 
> of Jetty 9.2.20 came before this fix.  See 
> [https://github.com/eclipse/jetty.project/issues/1804] and 
> [https://github.com/apache/hbase/blob/master/pom.xml#L1416.]
> This issue is to upgrade to 
> [9.3.22.v20171030|https://mvnrepository.com/artifact/org.eclipse.jetty/jetty-server/9.3.22.v20171030]
>  which is the latest version of 9.3



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Reply via email to