[ 
https://issues.apache.org/jira/browse/MADLIB-1209?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16373973#comment-16373973
 ] 

ASF GitHub Bot commented on MADLIB-1209:
----------------------------------------

Github user asfgit closed the pull request at:

    https://github.com/apache/madlib/pull/238


> Neural nets fails on Greenplum 4.3.x when verbose argument set to TRUE
> ----------------------------------------------------------------------
>
>                 Key: MADLIB-1209
>                 URL: https://issues.apache.org/jira/browse/MADLIB-1209
>             Project: Apache MADlib
>          Issue Type: Bug
>          Components: Module: Neural Networks
>            Reporter: Frank McQuillan
>            Priority: Minor
>             Fix For: v1.14
>
>
> In 
> {code}
> mlp_classification(
>     source_table,
>     output_table,
>     independent_varname,
>     dependent_varname,
>     hidden_layer_sizes,
>     optimizer_params,
>     activation,
>     weights,
>     warm_start,
>     verbose,
>     grouping_col
>     )
> {code}
> when the `verbose` argument is set to `TRUE` the following error results:
> {code}
> ERROR:  plpy.SPIError: function array_length(double precision[], integer) 
> does not exist (plpython.c:4656)
> LINE 4:                             _state_current[array_length(_sta...
>                                                    ^
> HINT:  No function matches the given name and argument types. You may need to 
> add explicit type casts.
> QUERY: 
>             SELECT
>                
>                             _state_current[array_length(_state_current,1)] AS 
> loss
>                           ,
>                 __madlib_temp_col_grp_key29688300_1519168141_31322353__
>             FROM (
>                 SELECT grp_key AS 
> __madlib_temp_col_grp_key29688300_1519168141_31322353__, state AS 
> _state_current FROM madlib._gen_state($3, NULL, $4)
>            ) subq1
>            
> CONTEXT:  Traceback (most recent call last):
>   PL/Python function "mlp_classification", line 33, in <module>
>     grouping_col
>   PL/Python function "mlp_classification", line 290, in mlp
>   PL/Python function "mlp_classification", line 455, in 
> get_param_value_per_group
> PL/Python function "mlp_classification"
> {code}
> because `array_length` does not exist in Greenplum 4.3.x . 
> It works OK in Greenplum 5.x and Postgres 9.x/10 however.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Reply via email to