[
https://issues.apache.org/jira/browse/MPIR-323?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14492254#comment-14492254
]
Michael Osipov commented on MPIR-323:
-------------------------------------
Hervé, I do only partially agree.
* {{integration}} is not a useful name, integration in what? Maybe
{{continuous-integration}} would be even better.
* {{mail-lists}} is fine as long as the class name contains the plural, as well
as the mojo.
* {{team-list}}, here I disagree because we already have {{project-X}}. It
would rather prefer to reuse that pattern.
> Align Mojo, class and output names
> ----------------------------------
>
> Key: MPIR-323
> URL: https://issues.apache.org/jira/browse/MPIR-323
> Project: Maven Project Info Reports Plugin
> Issue Type: Task
> Components: cim, mailing-list, project-team
> Affects Versions: 2.7
> Reporter: Michael Osipov
> Fix For: next-major
>
>
> Currently, names in those mojos are inconsistent with the rest:
> * {{CimReport}}: outputName is {{integration}} but should be {{cim}}
> * {{MailingListsReport}}:, Mojo name is {{mailing-list}} but should be,
> {{mailing-lists}}, outputName is {{mail-lists}} but should be
> {{mailing-lists}}
> * {{TeamListReport}}: class name should be {{ProjectTeamReport}}, outputName
> is {{team-list}} but should be {{project-team}}
--
This message was sent by Atlassian JIRA
(v6.3.4#6332)