[ 
https://issues.apache.org/jira/browse/SUREFIRE-1252?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15505160#comment-15505160
 ] 

Hudson commented on SUREFIRE-1252:
----------------------------------

SUCCESS: Integrated in Jenkins build maven-surefire #1621 (See 
[https://builds.apache.org/job/maven-surefire/1621/])
[SUREFIRE-1252] Tests not being run when using XML suite file with (tibor17: 
rev d60225741a8d65d9109d3bd28d3d019c19f120cb)
* (edit) 
surefire-providers/surefire-testng/src/main/java/org/apache/maven/surefire/testng/TestNGProvider.java
* (edit) 
surefire-providers/surefire-testng/src/main/java/org/apache/maven/surefire/testng/TestNGXmlTestSuite.java


> Tests not being run when using XML suite file with TestNG
> ---------------------------------------------------------
>
>                 Key: SUREFIRE-1252
>                 URL: https://issues.apache.org/jira/browse/SUREFIRE-1252
>             Project: Maven Surefire
>          Issue Type: Bug
>          Components: Maven Failsafe Plugin, Maven Surefire Plugin
>    Affects Versions: 2.19.1
>            Reporter: Samuel Andersson
>            Assignee: Tibor Digana
>             Fix For: 2.19.2
>
>
> When upgrading the surefire version to 2.19.1 I noticed that no tests were 
> being run in our integration tests. I managed to track down the error to this 
> commit and line:
> https://github.com/apache/maven-surefire/commit/9cefb7ba43b2550f3ede2952b47d079463c33328#diff-c4dee638bf96f8b3e7763d2652aab7efR207
> As you can see, no test suites is being returned when an XML test suite is 
> used.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Reply via email to