[ 
https://issues.apache.org/jira/browse/MENFORCER-248?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15711697#comment-15711697
 ] 

Julien Nicoulaud commented on MENFORCER-248:
--------------------------------------------

I confirm it happens with 1.4.1 and maven-assembly-plugin 3.0.0.

> Upgrading maven-enforcer-plugin to 1.4.1 breaks maven-assembly-plugin
> ---------------------------------------------------------------------
>
>                 Key: MENFORCER-248
>                 URL: https://issues.apache.org/jira/browse/MENFORCER-248
>             Project: Maven Enforcer Plugin
>          Issue Type: Bug
>          Components: Plugin
>            Reporter: Blazej Checinski
>            Assignee: Karl Heinz Marbaise
>             Fix For: 1.4.1
>
>         Attachments: extjars.xml, pom.xml
>
>
> After upgrading m-e-p from 1.4 to 1.4.1 the maven-assembly-plugin generates 
> the following error:
> [ERROR] Failed to execute goal 
> org.apache.maven.plugins:maven-assembly-plugin:2.4:single (assemble) on 
> project extjars: Execution assemble of goal 
> org.apache.maven.plugins:maven-assembly-plugin:2.4:single failed. 
> NullPointerException -> [Help 1]
> Downgrading to m-e-p 1.4 makes the assembly work again.
> Sample pom & assembly that expose the error attached.
> When called via:
> mvn -Dplugins.maven-enforcer-plugin.version=1.4
> a zip file is generated as expected, when called via
> mvn -Dplugins.maven-enforcer-plugin.version=1.4.1
> (or without argument) you will get the NPE.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Reply via email to