[ 
https://issues.apache.org/jira/browse/MDEPLOY-229?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16350190#comment-16350190
 ] 

Jakub Bochenski commented on MDEPLOY-229:
-----------------------------------------

This is actually 
https://github.com/HubSpot/dependency-management-maven-plugin/issues/13 but I 
can't close the issue for some reason

> Error injecting: org.apache.maven.artifact.deployer.DefaultArtifactDeployer 
> in Maven 3.3.9
> ------------------------------------------------------------------------------------------
>
>                 Key: MDEPLOY-229
>                 URL: https://issues.apache.org/jira/browse/MDEPLOY-229
>             Project: Maven Deploy Plugin
>          Issue Type: Bug
>          Components: deploy:deploy
>    Affects Versions: 2.8.2
>         Environment: Maven 3.3.9
>            Reporter: Jakub Bochenski
>            Priority: Critical
>
> The stacktrace is huge but I think the gist is:
> {code:java}
> java.lang.IllegalArgumentException: Can not set 
> org.eclipse.aether.spi.log.Logger field 
> org.apache.maven.repository.internal.DefaultVersionRangeResolver.logger to 
> org.eclipse.aether.internal.impl.slf4j.Slf4jLoggerFactory{code}
> Tried the same with Maven 3.5.0 and it works fine.
> Full stack trace: 
> https://gist.github.com/jakub-bochenski/08b7e9dce1823ef55c2335eb7e79fb14



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Reply via email to