[ 
https://issues.apache.org/jira/browse/MDEP-607?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16438646#comment-16438646
 ] 

Robert Scholte commented on MDEP-607:
-------------------------------------

Looks like an ASM issue. Can you try to add the latest asm version as 
dependency to the plugin in your pom?

> maven-dependency-plugin:3.1.0:analyze failed.: NullPointerException
> -------------------------------------------------------------------
>
>                 Key: MDEP-607
>                 URL: https://issues.apache.org/jira/browse/MDEP-607
>             Project: Maven Dependency Plugin
>          Issue Type: Bug
>          Components: analyze
>    Affects Versions: 3.1.0
>         Environment: mvn --version
> Apache Maven 3.5.3 (3383c37e1f9e9b3bc3df5050c29c8aff9f295297; 
> 2018-02-24T19:49:05Z)
> Maven home: /usr/local/Cellar/maven/3.5.3/libexec
> Java version: 1.8.0_162, vendor: Oracle Corporation
> Java home: 
> /Library/Java/JavaVirtualMachines/jdk1.8.0_162.jdk/Contents/Home/jre
> Default locale: en_PT, platform encoding: UTF-8
> OS name: "mac os x", version: "10.13.4", arch: "x86_64", family: "mac"
>            Reporter: Filipe Sousa
>            Priority: Major
>         Attachments: analyze-3.0.2.txt.gz, analyze-3.1.0.txt.gz, 
> image-2018-04-14-23-09-21-784.png, image-2018-04-14-23-10-37-681.png
>
>
> I'm having this NPE with 3.1.0. I have no problem with 3.0.2
> mvn org.apache.maven.plugins:maven-dependency-plugin:3.1.0:analyze
> I'm attaching the output of both versions.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Reply via email to