Kent Granström commented on MDEP-579:

Apologies [~pmoerenhout]. I made a typo and testing it after that it seems to 
work just fine. I can now use the "get" and it passes the creds nicely. I would 
concider this as solved, at least for me :). Perhaps a few testcases ought to 
be written for this, and similar, scenarios.

Many many thanks [~pmoerenhout]

> Regression: get goal does not pass server credentials to 
> BasicRepositoryConnector
> ---------------------------------------------------------------------------------
>                 Key: MDEP-579
>                 URL: https://issues.apache.org/jira/browse/MDEP-579
>             Project: Maven Dependency Plugin
>          Issue Type: Bug
>          Components: get
>    Affects Versions: 3.0.0, 3.0.1
>            Reporter: Richard W. Eggert II
>            Priority: Critical
>              Labels: credentials
>          Time Spent: 10m
>  Remaining Estimate: 0h
> The {{get}} goal does not pass the server credentials from {{settings.xml}} 
> to the {{BasicRepositoryConnector}} in version 3.0.1 (and, presumably 3.0.0), 
> resulting in {{NotAuthorized}} errors when resolving artifacts against 
> repositories that require authentication. It works correctly in version 2.9.
> Background: I discovered this in the course of debugging a Jenkins job in 
> which I'm using the {{get}} and {{copy}} goals from the command line (with no 
> POM) to download artifacts to deploy. After spending several hours thinking 
> that Jenkins was not properly configuring {{settings.xml}}, I noticed from 
> the Maven debug output that the credentials were being passed when resolving 
> the maven-dependency-plugin and its dependencies, but not being passed when 
> resolving the artifact I requested. On a hunch I downgraded from 
> maven-dependency-plugin version 3.0.1 to 2.9, and suddenly everything 
> magically worked.

This message was sent by Atlassian JIRA

Reply via email to