[ 
https://issues.apache.org/jira/browse/MPIR-383?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Robert Scholte closed MPIR-383.
-------------------------------
      Assignee: Robert Scholte
    Resolution: Duplicate

> Error when generation site with dependency build with Java 9+
> -------------------------------------------------------------
>
>                 Key: MPIR-383
>                 URL: https://issues.apache.org/jira/browse/MPIR-383
>             Project: Maven Project Info Reports Plugin
>          Issue Type: Bug
>          Components: dependencies
>    Affects Versions: 2.9, 3.0.0
>            Reporter: Alexander Gängel
>            Assignee: Robert Scholte
>            Priority: Minor
>
> When building a site with a dependency to log4j-api greather than {{2.9.1}} 
> the used the following error occurs.
> {code:java}
> [INFO] Generating "Dependencies" report  --- 
> maven-project-info-reports-plugin:2.9:dependencies
> [WARNING] Unable to process class META-INF/versions/9/module-info.class in 
> JarAnalyzer File 
> /Users/username/.m2/repository/org/apache/logging/log4j/log4j-api/2.11.2/log4j-api-2.11.2.jar
> org.apache.bcel.classfile.ClassFormatException: Invalid byte tag in constant 
> pool: 19
>     at org.apache.bcel.classfile.Constant.readConstant (Constant.java:161)
>     at org.apache.bcel.classfile.ConstantPool.<init> (ConstantPool.java:69)
>     at org.apache.bcel.classfile.ClassParser.readConstantPool 
> (ClassParser.java:235)
>     at org.apache.bcel.classfile.ClassParser.parse (ClassParser.java:143)
>     at org.apache.maven.shared.jar.classes.JarClassesAnalysis.analyze 
> (JarClassesAnalysis.java:96)
>     at 
> org.apache.maven.report.projectinfo.dependencies.Dependencies.getJarDependencyDetails
>  (Dependencies.java:259)
>     at 
> org.apache.maven.report.projectinfo.dependencies.renderer.DependenciesRenderer.hasSealed
>  (DependenciesRenderer.java:1542)
>     at 
> org.apache.maven.report.projectinfo.dependencies.renderer.DependenciesRenderer.renderSectionDependencyFileDetails
>  (DependenciesRenderer.java:545)
>     at 
> org.apache.maven.report.projectinfo.dependencies.renderer.DependenciesRenderer.renderBody
>  (DependenciesRenderer.java:240)
>     at org.apache.maven.reporting.AbstractMavenReportRenderer.render 
> (AbstractMavenReportRenderer.java:83)
>     at org.apache.maven.report.projectinfo.DependenciesReport.executeReport 
> (DependenciesReport.java:201)
>     at org.apache.maven.reporting.AbstractMavenReport.generate 
> (AbstractMavenReport.java:255)
>     at 
> org.apache.maven.plugins.site.render.ReportDocumentRenderer.renderDocument 
> (ReportDocumentRenderer.java:230)
>     at org.apache.maven.doxia.siterenderer.DefaultSiteRenderer.render 
> (DefaultSiteRenderer.java:349)
>     at org.apache.maven.plugins.site.render.SiteMojo.renderLocale 
> (SiteMojo.java:198)
>     at org.apache.maven.plugins.site.render.SiteMojo.execute 
> (SiteMojo.java:147)
>     at org.apache.maven.plugin.DefaultBuildPluginManager.executeMojo 
> (DefaultBuildPluginManager.java:137)
>     at org.apache.maven.lifecycle.internal.MojoExecutor.execute 
> (MojoExecutor.java:210)
>     at org.apache.maven.lifecycle.internal.MojoExecutor.execute 
> (MojoExecutor.java:156)
>     at org.apache.maven.lifecycle.internal.MojoExecutor.execute 
> (MojoExecutor.java:148)
>     at 
> org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject 
> (LifecycleModuleBuilder.java:117)
>     at 
> org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject 
> (LifecycleModuleBuilder.java:81)
>     at 
> org.apache.maven.lifecycle.internal.builder.singlethreaded.SingleThreadedBuilder.build
>  (SingleThreadedBuilder.java:56)
>     at org.apache.maven.lifecycle.internal.LifecycleStarter.execute 
> (LifecycleStarter.java:128)
>     at org.apache.maven.DefaultMaven.doExecute (DefaultMaven.java:305)
>     at org.apache.maven.DefaultMaven.doExecute (DefaultMaven.java:192)
>     at org.apache.maven.DefaultMaven.execute (DefaultMaven.java:105)
>     at org.apache.maven.cli.MavenCli.execute (MavenCli.java:956)
>     at org.apache.maven.cli.MavenCli.doMain (MavenCli.java:288)
>     at org.apache.maven.cli.MavenCli.main (MavenCli.java:192)
>     at jdk.internal.reflect.NativeMethodAccessorImpl.invoke0 (Native Method)
>     at jdk.internal.reflect.NativeMethodAccessorImpl.invoke 
> (NativeMethodAccessorImpl.java:62)
>     at jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke 
> (DelegatingMethodAccessorImpl.java:43)
>     at java.lang.reflect.Method.invoke (Method.java:567)
>     at org.codehaus.plexus.classworlds.launcher.Launcher.launchEnhanced 
> (Launcher.java:282)
>     at org.codehaus.plexus.classworlds.launcher.Launcher.launch 
> (Launcher.java:225)
>     at org.codehaus.plexus.classworlds.launcher.Launcher.mainWithExitCode 
> (Launcher.java:406)
>     at org.codehaus.plexus.classworlds.launcher.Launcher.main 
> (Launcher.java:347)
> {code}
> This occurs because the dependency is too old:
> {code:java}
> <dependency>
>   <groupId>org.apache.bcel</groupId>
>   <artifactId>bcel</artifactId>
>   <version>6.2</version>
> </dependency>{code}
> updating this would work but then the minimal javaVersion must be upgraded to 
> 8
> I could open a pull request if you like.
> Regards
> Alex



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

Reply via email to