[ 
https://issues.apache.org/jira/browse/MESOS-2211?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14284648#comment-14284648
 ] 

Kapil Arya commented on MESOS-2211:
-----------------------------------

I have created a RR for updating the style guide to reflect our usage of 
`#pragma once` instead of `#define` guard for our header files: 

https://reviews.apache.org/r/30100/

This is also meant to get a consensus on the proposal.

> Include guard naming fixup
> --------------------------
>
>                 Key: MESOS-2211
>                 URL: https://issues.apache.org/jira/browse/MESOS-2211
>             Project: Mesos
>          Issue Type: Bug
>            Reporter: Till Toenshoff
>            Assignee: Kapil Arya
>            Priority: Trivial
>              Labels: newbie
>
> Triggered by a comment in a review request, I noticed that we currently have 
> no consistent style for naming include guards.
> Examples: 
> include/mesos/resources.hpp: {{#define __RESOURCES_HPP__}}
> include/mesos/executor.hpp: {{#define __MESOS_EXECUTOR_HPP__}}
> include/mesos/mesos.hpp: {{#define __MESOS_HPP__}}
> I think the **right** way would be stating the path and include file name 
> within the guard, so the above at fault become:
> include/mesos/resources.hpp: {{#define __MESOS_RESOURCES_HPP__}}
> include/mesos/mesos.hpp: {{#define __MESOS_MESOS_HPP__}}
> Everything from include/XXX should have a __XXX_ prefix in its guard name, 
> anything from src/XXX should have a __XXX_ prefix. This should also apply to 
> multiple folder levels; e.g. include/XXX/YYY/FOO should have a __XXX_YYY_FOO 
> prefix.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Reply via email to