[ 
https://issues.apache.org/jira/browse/MESOS-6350?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Benjamin Bannier updated MESOS-6350:
------------------------------------
    Description: We currently require at least cmake-2.8 which had its first 
point release 2010 and last update 2013. Meanwhile upstream is preparing the 
release of 3.7.0. While cmake support in Mesos is still experimental we should 
evaluate how much we can increase the minimal required version so we are not 
locked into an old version lacking desirable features.  (was: It seems cmake's 
{{BYPRODUCTS}} or {{BUILD_BYPRODUCTS}} clauses are the correct tool to properly 
model implicitly generated 3rdparty artifacts.

However these are only available in cmake-3.2 or 3.3, respectively. 
https://cmake.org/cmake/help/v3.3/policy/CMP0058.html

We should evaluate what is holding us back to upgrade 
{{cmake_minimum_required}} to at least 3.3. Meanwhile upstream is preparing the 
release of 3.7.0. )
        Summary: Raise minimum required cmake version  (was: Raised minimum 
required cmake version)

> Raise minimum required cmake version
> ------------------------------------
>
>                 Key: MESOS-6350
>                 URL: https://issues.apache.org/jira/browse/MESOS-6350
>             Project: Mesos
>          Issue Type: Improvement
>          Components: cmake
>            Reporter: Benjamin Bannier
>              Labels: mesosphere, tech-debt
>
> We currently require at least cmake-2.8 which had its first point release 
> 2010 and last update 2013. Meanwhile upstream is preparing the release of 
> 3.7.0. While cmake support in Mesos is still experimental we should evaluate 
> how much we can increase the minimal required version so we are not locked 
> into an old version lacking desirable features.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Reply via email to