[ 
https://issues.apache.org/jira/browse/NIFI-2798?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15572498#comment-15572498
 ] 

Joseph Witt commented on NIFI-2798:
-----------------------------------

I don't believe we distribute or have a relationship to the C client.  If that 
is the case it doesn't apply to us and seems like it can be marked as WONTFIX.

> Upgrade Zookeeper version due to CVE-2016-5017
> ----------------------------------------------
>
>                 Key: NIFI-2798
>                 URL: https://issues.apache.org/jira/browse/NIFI-2798
>             Project: Apache NiFi
>          Issue Type: Task
>          Components: Core Framework
>    Affects Versions: 1.0.0, 0.7.0
>            Reporter: Andy LoPresto
>            Priority: Critical
>              Labels: cve, security, zookeeper
>             Fix For: 1.1.0, 0.8.0
>
>   Original Estimate: 4h
>  Remaining Estimate: 4h
>
> The currently used version of Zookeeper {{3.4.6}} is subject to a buffer 
> overflow attack using the C command-line interface (documented as 
> CVE-2016-5017 [1]). Version {{3.4.9}} patches this issue. In 
> {{nifi/pom.xml}}, this version number should be updated, and basic 
> compatibility/smoke tests should be run to ensure no new issues are 
> introduced by the version increment. 
> [1] https://zookeeper.apache.org/security.html#CVE-2016-5017



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Reply via email to