ASF GitHub Bot commented on NIFI-2899:

Github user simplesteph commented on the issue:

    No worries, I’ll build it on my own in my separate repos, see if people
    have any usage for it, and based on adoption thinking of merging this into
    the base.
    What I really like though is that the documentation generated for the API
    is stellar.
    On 14 October 2016 at 11:26:08 AM, Andy LoPresto (notificati...@github.com)
    I don't think that's something we should do at this time. The NiFi build is
    already long enough (10 - 20 minutes on commodity hardware depending on
    multithreading, tests, and contrib-check) and I don't think many people
    need this functionality, much less in multiple languages, and I don't know
    how we would determine the default languages -- maybe just Java to start as
    that's what the codebase is written in?
    If you want to submit a PR for a custom profile that builds the API
    clients, I wouldn't object to that as long as it was disabled by default.
    Not sure what others' feelings are.
    You are receiving this because you authored the thread.
    Reply to this email directly, view it on GitHub
    <https://github.com/apache/nifi/pull/1135#issuecomment-253677513>, or mute
    the thread

> Update swagger-maven-plugin to 3.0.1 to have a spec-compliant swagger.json
> --------------------------------------------------------------------------
>                 Key: NIFI-2899
>                 URL: https://issues.apache.org/jira/browse/NIFI-2899
>             Project: Apache NiFi
>          Issue Type: Bug
>          Components: Documentation & Website
>    Affects Versions: 1.0.0
>            Reporter: Stephane Maarek
>            Assignee: Andy LoPresto
>             Fix For: 1.1.0
> I tried using swagger-codegen with the generated swagger.json but it gave me 
> errors.
> I opened a bug report on their project at 
> https://github.com/swagger-api/swagger-codegen/issues/3976, and after 
> investigation, our current swagger-maven-plugin produces a swagger.json file 
> with "type" : "ref" in it. This is non compliant with the specs, and a fix 
> was introduced in https://github.com/kongchen/swagger-maven-plugin/issues/141 
> Therefore, we need to upgrade the swagger-maven-plugin from 3.0-M1 to 3.0.1. 
> I tested it and it works now with the swagger-codegen plugin. Happy to submit 
> a PR, let me know your thoughts

This message was sent by Atlassian JIRA

Reply via email to