[ 
https://issues.apache.org/jira/browse/NIFI-12446?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=17793125#comment-17793125
 ] 

David Handermann commented on NIFI-12446:
-----------------------------------------

Thanks for working on this [~EndzeitBegins]. I will leave this issue open for 
now pending a new pull request for the main branch.

> Align implementation of FilterAttribute with coding conventions
> ---------------------------------------------------------------
>
>                 Key: NIFI-12446
>                 URL: https://issues.apache.org/jira/browse/NIFI-12446
>             Project: Apache NiFi
>          Issue Type: Improvement
>            Reporter: endzeit
>            Assignee: endzeit
>            Priority: Major
>              Labels: backport-needed
>             Fix For: 1.25.0
>
>         Attachments: image-2023-11-30-16-18-43-040.png
>
>          Time Spent: 3h 40m
>  Remaining Estimate: 0h
>
> The new processor {{FilterAttribute}} should be aligned with common coding 
> conventions followed by other Processor components.
> This applies to the implementation both on the s{{{}upport/nifi-1.x{}}} and 
> {{main}} branch, unless mentioned otherwise.
> Desired changes:
>  * rename property "Filter mode" ("FILTER_MODE") to "Filter Mode" ("Filter 
> Mode") 
>  * rename property "Attribute matching strategy" ("MATCHING_STRATEGY") to 
> "Attribute Matching Strategy" ("Attribute Matching Strategy") 
>  * rename property "Set of attributes to filter" ("ATTRIBUTE_SET") to 
> "Filtered Attributes" ("Filtered Attributes")
>  * rename property "Regular expression to filter attributes" 
> ("ATTRIBUTE_REGEX") to "Filtered Attributes Pattern" ("Filtered Attributes 
> Pattern")
>  * rename MatchingStrategy.REGEX to MatchingStrategy.PATTERN
>  * use toString() on Enum entry instead of raw String, when declaring 
> AllowableValue for Filter Mode 
>  * move field cachedMatchingPredicate before the method declarations
>  * remove exclamation mark from IllegalArgumentExceptiion; put actual 
> strategy value in [] (support/nifi-1.x only)
>  * use Collections.unmodifiableList(Arrays.asList(...)) instead of 
> _propertyDescriptors (support/nifi-1.x only)
>  * replace !attributeName.trim().isEmpty() with 
> attributeName.trim().isEmpty().not() 
>  * align AllowableValue value and displayName fields to the same string as 
> "Title Case"



--
This message was sent by Atlassian Jira
(v8.20.10#820010)

Reply via email to