Jussi Talaskivi created NIFI-16393:
--------------------------------------
Summary: SMB processors fail randomly with Isilon NAS
Key: NIFI-16393
URL: https://issues.apache.org/jira/browse/NIFI-16393
Project: Apache NiFi
Issue Type: Bug
Environment: RHEL9, Nomad job running with Podman driver using the
official Docker image.
Reporter: Jussi Talaskivi
Attachments: GetSmbFile-1.txt
I have tried to get SMB connections to work from NiFi 2.12 cluster to Isilon
NAS (OneFS 9.3). I have tried using ListSMB, FetchSMB and GetSMB processors.
The problem is that processors fail with random errors or sometimes they
succeed.
I have used the following properties in the SmbjClientProviderService:
* SMB Dialect: 3.1.1
* Use Encryption: true
* Enable DFS: false
Using DFS was a show-stopper from the start.
I'm suspecting the problem is related of re-using client connections. Trying to
use connection that has already been closed or something. I have attached
couple of stacktraces that I captured when trying to use GetSMB.
--
This message was sent by Atlassian Jira
(v8.20.10#820010)