[
https://issues.apache.org/jira/browse/MINIFICPP-36?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16188237#comment-16188237
]
ASF subversion and git services commented on MINIFICPP-36:
----------------------------------------------------------
Commit 9f161a27e5fa0ea9aac4d59d1c23edbad3d77858 in nifi-minifi-cpp's branch
refs/heads/master from Marc Parisi
[ https://git-wip-us.apache.org/repos/asf?p=nifi-minifi-cpp.git;h=9f161a2 ]
MINIFI-339: Add C2 base allowing for 1 protocol and n heartbeat reporters
MINIFI-339: Add GetTCP Processor
MINIFI-339: Add listener server
MINIFI-339: Update to listener
MINIFI-339: Resolve Issue with stack based processor nodes losing scope
MINIFI-369: Update ListenHTTP processor to allow transfer encoding
MINIFI-339: Update rest receiver instantiation and fix issue found in GetFile
MINIFI-339: Rename content to operational arguments
MINIFI-371: remove virtual destructors when not needed
MINIFI-339: Fixing issues with GetTCP
MINIFI-378: Resolve issues with shutdown. Took the approach to call notifyStop
at the destructor to avoid larger changes
MINIFI-339: Allow C2 to be disabled
This closes #134.
Signed-off-by: Aldrin Piri <[email protected]>
> Begin building controlling API to facilitate control of agents
> --------------------------------------------------------------
>
> Key: MINIFICPP-36
> URL: https://issues.apache.org/jira/browse/MINIFICPP-36
> Project: NiFi MiNiFi C++
> Issue Type: New Feature
> Reporter: marco polo
> Assignee: marco polo
> Priority: Critical
> Labels: Durability, Reliability, Statistics
>
> Begin building the controlling API in MiNiFi C++. This API will evolve and
> likely have public and private elements. As development progresses we may
> want more capabilities.
> What I want to create as a straw man will be basic control and metrics
> gathering
> -- Start
> -- Stop
> -- Pause
> -- Gather metrics
> ** Throughput of of flow components
> ** Execution time ( run time minus sleep time )
> ** Memory consumption
> -- Drain repositories
> -- Switch repository types.
> Better employ update listener within this controlling API
--
This message was sent by Atlassian JIRA
(v6.4.14#64029)