[ 
https://issues.apache.org/jira/browse/NIFI-4848?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16361770#comment-16361770
 ] 

Koji Kawamura commented on NIFI-4848:
-------------------------------------

[~pvillard] Thanks for the heads up about version compatibility with HTTPS S2S 
between NiFi and MiNiFi.

I tested following Secured S2S HTTP combination:
*  To Remote NiFi 1.6.0-SNAPSHOT using httpcore-4.4.9 and httpclient-4.5.5
*  From MiNiFi 1.5.0 using nifi-site-to-site-1.5.0, httpcore-4.4.4.jar and 
httpclient-4.5.3.jar = Worked
*  From MiNiFi 1.5.0 using nifi-site-to-site-1.6.0-SNAPSHOT, httpcore-4.4.4.jar 
and httpclient-4.5.3.jar = Worked

>From above results, the updates made by this JIRA particularly does not seem 
>affecting MiNiFi and NiFi Secure HTTP S2S connectivity. I will try not to 
>forget test about it when I vote next MiNiFi release, though.

> Update HttpComponents version
> -----------------------------
>
>                 Key: NIFI-4848
>                 URL: https://issues.apache.org/jira/browse/NIFI-4848
>             Project: Apache NiFi
>          Issue Type: Improvement
>          Components: Core Framework
>            Reporter: Koji Kawamura
>            Assignee: Koji Kawamura
>            Priority: Major
>             Fix For: 1.6.0
>
>
> Following dependencies should be updated to the latest GA:
> httpclient 4.5.3 -> 4.5.5
> httpcore 4.4.4 -> 4.4.9
> httpasyncclient 4.1.2 -> 4.1.3



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Reply via email to