neerajmangal edited a comment on issue #4683: Fix Travis build pip install 
issue in pre installation step
URL: https://github.com/apache/openwhisk/pull/4683#issuecomment-540970583
 
 
   Pip issue is solved by adding "--user" flag and adding python3-pip. Travis 
builds are failing now with this issue. 
   
   ```bash
   > Task :swagger-java-client:compileJava
   
/home/travis/build/apache/openwhisk/tests/build/swagger-code-java/src/main/java/io/swagger/client/ApiException.java:19:
 error: package javax.annotation does not exist
   @javax.annotation.Generated(value = 
"io.swagger.codegen.languages.JavaClientCodegen", date = 
"2019-10-11T06:14:22.400Z")
                    ^
   ```
   
   Seems like the default version of java is picked as 11. 
   ```bash
   java -Xmx32m -version
   openjdk version "11.0.2" 2019-01-15
   OpenJDK Runtime Environment 18.9 (build 11.0.2+9)
   OpenJDK 64-Bit Server VM 18.9 (build 11.0.2+9, mixed mode)
   $ javac -J-Xmx32m -version
   javac 11.0.2
   ```
   and it's causing the issue with the swagger doc compilation issue above due 
to the removal of javax libs. 
   
   Fix - 
   
   1. Added dist as xenial 
   2. Pin JDK version to openjdk8
   3. Added python3-pip package
   
   For future stability, I think we should completely move to python version 
3.x as currently, our build, test system is integrated with python2.7 which 
will be deprecated in Jan 2020.
   
   Please let me know your feedback.  
   

----------------------------------------------------------------
This is an automated message from the Apache Git Service.
To respond to the message, please log on to GitHub and use the
URL above to go to the specific comment.
 
For queries about this service, please contact Infrastructure at:
us...@infra.apache.org


With regards,
Apache Git Services

Reply via email to