misl commented on issue #2590: Feature request: Allow java action entrypoint 
method name to be configurable
   Having the option to control the entrypoint name allows me to have multiple 
entrypoints in the same class. For instance a create and an update action on 
the same model are very similar, why should I be **forced** to separate them 
over 2 classes.
   I did a small test to see the impact of a separate class on jar size:
   - Add same entrypoint to different class increased jar file by 700 bytes
   - Duplicating the entrypoint in the same class (with different name) 
increases jar file by 27 bytes
   This was done with a plain hello world action.
   I know that if I was really concerned about jar size I should include only a 
single action in the jar file and remove everything not used by that single 
action. But from a coding perspective (sourcecode readability) this separation 
seems like additional complexity to me, making it harder to understand. I like 
to see it more like a REST resource, where I would put the various operations 
on that resource close together as well.
This is an automated message from the Apache Git Service.
To respond to the message, please log on GitHub and use the
URL above to go to the specific comment.
For queries about this service, please contact Infrastructure at:

With regards,
Apache Git Services

Reply via email to