davglass commented on issue #2220: Ansible error while deploying to distributed 
   I'm having a similar error, I wrestled with it all day yesterday and still 
can't figure out the issue. I have a raw OpenStack Ocata deployment with a 
single boot strapper node that I am executing the ansible commands from. I'm 
currently running from the `master` branch. I have a single deployment that 
worked perfect. My next test was to use OpenStack to deploy a scalable 
distributed system. 
   The error I get when I run `ansible-playbook -i environments/distributed 
provision_env_dist.yml` is:
   TASK [set vars] 
   Tuesday 06 March 2018  14:37:45 +0000 (0:00:00.045)       0:00:01.693 
   fatal: [ansible]: FAILED! => {"failed": true, "msg": "the field 'args' has 
an invalid value, which appears to include a variable that is undefined. The 
error was:
    'ansible.vars.unsafe_proxy.AnsibleUnsafeText object' has no attribute 
'name'\n\nThe error appears to have been in 
'/home/ubuntu/openwhisk/ansible/boot_instances_dist.yml': line 4, column 3, but 
may\nbe elsewhere in the file depending on the exact syntax problem.\n\nThe 
offending line appears to be:\n\n# TODO, in \"with_instance\" loops, the 
\"instance\" variable that is passed in gets unset, look up the proper way to 
do nested loops\n- name: set vars\n  ^ here\n"}
   Full error output here: 
   Any help would be very appreciated, thanks!

This is an automated message from the Apache Git Service.
To respond to the message, please log on GitHub and use the
URL above to go to the specific comment.
For queries about this service, please contact Infrastructure at:

With regards,
Apache Git Services

Reply via email to