[ 
https://issues.apache.org/jira/browse/HDDS-14961?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Wei-Chiu Chuang updated HDDS-14961:
-----------------------------------
    Release Note: 
Changed

OpenTelemetry tracing settings can be configured in ozone-site.xml via 
ozone.tracing.enabled, ozone.tracing.endpoint, ozone.tracing.sampler, and 
ozone.tracing.span.sampling. (HDDS-14961)
hdds.tracing.enabled is deprecated; use ozone.tracing.enabled instead. The old 
key still works in this release but will be removed in a future release.
When both ozone-site.xml and OTEL_* environment variables are set, 
configuration keys take precedence over env vars.
Upgrade notes

No change required if you only use hdds.tracing.enabled and OTEL_* env vars — 
existing setups keep working.
Rename hdds.tracing.enabled → ozone.tracing.enabled in ozone-site.xml.
Optional: move OTEL_EXPORTER_OTLP_ENDPOINT, OTEL_TRACES_SAMPLER_ARG, and 
OTEL_SPAN_SAMPLING_ARG into the matching ozone.tracing.* keys for centralized 
configuration.
Restart OM, SCM, DataNode, and clients after changing tracing settings.
Ensure sampler values are in the range 0.0–1.0; invalid values can prevent 
tracing from starting.

> Introduce configuration for tracing
> -----------------------------------
>
>                 Key: HDDS-14961
>                 URL: https://issues.apache.org/jira/browse/HDDS-14961
>             Project: Apache Ozone
>          Issue Type: Sub-task
>            Reporter: Sravani Revuri
>            Assignee: Sravani Revuri
>            Priority: Major
>              Labels: pull-request-available
>             Fix For: 2.2.0
>
>
> Currently, OpenTelemetry tracing in {{TracingUtil}} relies on environment 
> variables {{{}OTEL_EXPORTER_OTLP_ENDPOINT{}}}, 
> {{{}OTEL_TRACES_SAMPLER_ARG{}}}, and {{{}OTEL_SPAN_SAMPLING_ARG{}}}. which 
> cannot be updated dynamically.
> Moving these to the below configs to enable dynamic update.
>  * {{OTEL_EXPORTER_OTLP_ENDPOINT}} → {{ozone.tracing.endpoint}}
>  * {{OTEL_TRACES_SAMPLER_ARG}} → {{ozone.tracing.sampler}}
>  * {{OTEL_SPAN_SAMPLING_ARG}} → {{ozone.tracing.span.sampling}}
>  * Update {{hdds.tracing.enabled}} to {{ozone.tracing.enabled}} to align with 
> the new naming convention.
>  



--
This message was sent by Atlassian Jira
(v8.20.10#820010)

---------------------------------------------------------------------
To unsubscribe, e-mail: [email protected]
For additional commands, e-mail: [email protected]

Reply via email to