[ 
https://issues.apache.org/jira/browse/HDDS-12774?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Attila Doroszlai updated HDDS-12774:
------------------------------------
    Summary: Improve BucketForTesting  (was: Improve TestBucket)

> Improve BucketForTesting
> ------------------------
>
>                 Key: HDDS-12774
>                 URL: https://issues.apache.org/jira/browse/HDDS-12774
>             Project: Apache Ozone
>          Issue Type: Sub-task
>          Components: test
>            Reporter: Attila Doroszlai
>            Priority: Major
>
> - Allow setting volume and volume/bucket name in {{TestBucket.Builder}} (see 
> TODO comments)
> - The name {{TestBucket}} indicates it is a test, but in reality it is a 
> helper.  Rename the class according to naming conventions (e.g. 
> BucketForTest).
> - Use it instead of {{TestHelper#createKey}} and {{TestDataUtil#createKey}}.



--
This message was sent by Atlassian Jira
(v10.3.26#10030026)

---------------------------------------------------------------------
To unsubscribe, e-mail: [email protected]
For additional commands, e-mail: [email protected]

Reply via email to