Rui Wang created HDDS-17704:
-------------------------------

             Summary: Rename HDDSVersion STREAM_PUTBLOCK_WITHOUT_RAFT to 
CHAINED_REPLICATION
                 Key: HDDS-17704
                 URL: https://issues.apache.org/jira/browse/HDDS-17704
             Project: Apache Ozone
          Issue Type: Sub-task
          Components: Ozone Datanode
            Reporter: Rui Wang
            Assignee: Rui Wang
             Fix For: 2.3.0


HDDS-16910 added HDDSVersion.STREAM_PUTBLOCK_WITHOUT_RAFT(101). The client 
requires every datanode in a
pipeline to be at this version before it commits PutBlock through a Ratis data 
stream instead of the Raft log.


Committing PutBlock without Raft is the first step of streaming write without 
raft, or call it chained replication. HDDSVersion STREAM_PUTBLOCK_WITHOUT_RAFT 
as a version name is too narrow for the bigger feature.


Compatibility: the version has not been in any release yet (not in 2.1.x or 
2.2.x), so now is the time to rename
it. The serialized value stays 101, so the wire format is unchanged. Only the 
Java constant name changes.




--
This message was sent by Atlassian Jira
(v10.3.26#10030026)

---------------------------------------------------------------------
To unsubscribe, e-mail: [email protected]
For additional commands, e-mail: [email protected]

Reply via email to