[ 
https://issues.apache.org/jira/browse/ROCKETMQ-96?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

yukon updated ROCKETMQ-96:
--------------------------
    Fix Version/s: 4.1.0-incubating

> Rename tmp variable 
> --------------------
>
>                 Key: ROCKETMQ-96
>                 URL: https://issues.apache.org/jira/browse/ROCKETMQ-96
>             Project: Apache RocketMQ
>          Issue Type: Improvement
>          Components: rocketmq-client
>    Affects Versions: 4.0.0-incubating
>            Reporter: Jaskey Lam
>            Assignee: Jaskey Lam
>            Priority: Minor
>             Fix For: 4.1.0-incubating
>
>
> Some variable is named with tmp which is very difficult to read and 
> understand its usage.
> For exampe:
> 1. in sendDefaultImpl, when select message queue, the variable is named with 
>     
>       MessageQueue tmpmq = this.selectOneMessageQueue(topicPublishInfo, 
> lastBrokerName);
> 2. In process queue, a field is named `msgTreeMapTemp`, which takes me 
> minutes to understand why it is desgined for, which should be rename to some 
> name like consumeingOrderlyMsgTreeMap



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Reply via email to