[ 
https://issues.apache.org/jira/browse/SPARK-17605?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15506013#comment-15506013
 ] 

Apache Spark commented on SPARK-17605:
--------------------------------------

User 'zjffdu' has created a pull request for this issue:
https://github.com/apache/spark/pull/15159

> Add option spark.usePython and spark.useR for applications that use both 
> pyspark and sparkr
> -------------------------------------------------------------------------------------------
>
>                 Key: SPARK-17605
>                 URL: https://issues.apache.org/jira/browse/SPARK-17605
>             Project: Spark
>          Issue Type: Improvement
>          Components: Spark Submit
>            Reporter: Jeff Zhang
>
> For applications (zeppelin & livy ) that use both pyspark and sparkr, we have 
> to duplicate the code in SparkSubmit to figure the where is the requirement 
> resources for pyspark & sparkr (pyspark.zip, py4j, sparkr.zip and R file in 
> jars). It would be better to provide option spark.usePython and spark.useR, 
> so that downstream project which use both pyspark and sparkr in one spark 
> application don't need to duplicate the code in SparkSubmit, can just 
> leverage these 2 options. 



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: issues-unsubscr...@spark.apache.org
For additional commands, e-mail: issues-h...@spark.apache.org

Reply via email to