[
https://issues.apache.org/jira/browse/SPARK-20303?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]
Xiao Li updated SPARK-20303:
----------------------------
Summary: Rename createTempFunction to registerFunction (was: Replace
createTempFunction by registerFunction)
> Rename createTempFunction to registerFunction
> ---------------------------------------------
>
> Key: SPARK-20303
> URL: https://issues.apache.org/jira/browse/SPARK-20303
> Project: Spark
> Issue Type: Improvement
> Components: SQL
> Affects Versions: 2.2.0
> Reporter: Xiao Li
> Assignee: Xiao Li
>
> Session catalog API `createTempFunction` is being used by Hive build-in
> functions, persistent functions, and temporary functions. Thus, the name is
> confusing. This PR is to replace it by `registerFunction`. Also we can move
> construction of `FunctionBuilder` and `ExpressionInfo` into the new
> `registerFunction`, instead of duplicating the logics everywhere.
--
This message was sent by Atlassian JIRA
(v6.3.15#6346)
---------------------------------------------------------------------
To unsubscribe, e-mail: [email protected]
For additional commands, e-mail: [email protected]