[ 
https://issues.apache.org/jira/browse/SPARK-20391?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16060097#comment-16060097
 ] 

Jose Soltren commented on SPARK-20391:
--------------------------------------

So, this is months old now and irrelevant, but since you pinged me, I'll say 
that jerryshao's changes look fine to me. Thanks.

> Properly rename the memory related fields in ExecutorSummary REST API
> ---------------------------------------------------------------------
>
>                 Key: SPARK-20391
>                 URL: https://issues.apache.org/jira/browse/SPARK-20391
>             Project: Spark
>          Issue Type: Improvement
>          Components: Spark Core
>    Affects Versions: 2.2.0
>            Reporter: Saisai Shao
>            Assignee: Saisai Shao
>            Priority: Blocker
>             Fix For: 2.2.0
>
>
> Currently in Spark we could get executor summary through REST API 
> {{/api/v1/applications/<app-id>/executors}}. The format of executor summary 
> is:
> {code}
> class ExecutorSummary private[spark](
>     val id: String,
>     val hostPort: String,
>     val isActive: Boolean,
>     val rddBlocks: Int,
>     val memoryUsed: Long,
>     val diskUsed: Long,
>     val totalCores: Int,
>     val maxTasks: Int,
>     val activeTasks: Int,
>     val failedTasks: Int,
>     val completedTasks: Int,
>     val totalTasks: Int,
>     val totalDuration: Long,
>     val totalGCTime: Long,
>     val totalInputBytes: Long,
>     val totalShuffleRead: Long,
>     val totalShuffleWrite: Long,
>     val isBlacklisted: Boolean,
>     val maxMemory: Long,
>     val executorLogs: Map[String, String],
>     val onHeapMemoryUsed: Option[Long],
>     val offHeapMemoryUsed: Option[Long],
>     val maxOnHeapMemory: Option[Long],
>     val maxOffHeapMemory: Option[Long])
> {code}
> Here are 6 memory related fields: {{memoryUsed}}, {{maxMemory}}, 
> {{onHeapMemoryUsed}}, {{offHeapMemoryUsed}}, {{maxOnHeapMemory}}, 
> {{maxOffHeapMemory}}.
> These all 6 fields reflects the *storage* memory usage in Spark, but from the 
> name of this 6 fields, user doesn't really know it is referring to *storage* 
> memory or the total memory (storage memory + execution memory). This will be 
> misleading.
> So I think we should properly rename these fields to reflect their real 
> meanings. Or we should will document it.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

---------------------------------------------------------------------
To unsubscribe, e-mail: issues-unsubscr...@spark.apache.org
For additional commands, e-mail: issues-h...@spark.apache.org

Reply via email to