Marcelo Vanzin commented on SPARK-18673:

We can't close this because Spark is not using the latest version of Hive. So 
even if Hive is fixed, Spark is still not.

> Dataframes doesn't work on Hadoop 3.x; Hive rejects Hadoop version
> ------------------------------------------------------------------
>                 Key: SPARK-18673
>                 URL: https://issues.apache.org/jira/browse/SPARK-18673
>             Project: Spark
>          Issue Type: Bug
>          Components: SQL
>    Affects Versions: 2.1.0
>         Environment: Spark built with -Dhadoop.version=3.0.0-alpha2-SNAPSHOT 
>            Reporter: Steve Loughran
>            Priority: Major
> Spark Dataframes fail to run on Hadoop 3.0.x, because hive.jar's shimloader 
> considers 3.x to be an unknown Hadoop version.
> Hive itself will have to fix this; as Spark uses its own hive 1.2.x JAR, it 
> will need to be updated to match.

This message was sent by Atlassian JIRA

To unsubscribe, e-mail: issues-unsubscr...@spark.apache.org
For additional commands, e-mail: issues-h...@spark.apache.org

Reply via email to