[ 
https://issues.apache.org/jira/browse/SPARK-5388?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14308598#comment-14308598
 ] 

Andrew Or commented on SPARK-5388:
----------------------------------

[~tigerquoll] I still don't think we should use DELETE for kill for the 
following reason. In normal REST servers that host static resources, if you GET 
after a DELETE, you run into a 404. Here, our resources are by no means static, 
and if you GET after a DELETE you actually get a different status (that your 
driver is now KILLED instead of RUNNING) instead. Because of these side-effects 
I think it is safest to use POST.

[~vanzin]
- The action field is actually required especially since many of the responses 
look quite alike. We need to know how to deserialize the messages safely in 
case the response we get from the server is not the type that we expect it to 
be (e.g. ErrorResponse).
- Yes, I could rename the protocolVersion field.
- The issue with having non-String types is that you will need to deal with 
numeric and boolean values specially. For instance, if the user does not 
explicitly set the field there is no easy way to not include it in the JSON 
without doing some Option hack. I went down that route and opted out for 
simpler code.
- The unknown fields reporting is added in the PR but is missing in the spec. 
In the PR it is reported in its own explicit field.
- Even in the existing interface you can use o.a.s.deploy.Client to kill an 
application, and the security guarantees there are the same. I agree that it is 
something we need to address that at some point, but I prefer to keep that 
outside the scope of this patch.

> Provide a stable application submission gateway in standalone cluster mode
> --------------------------------------------------------------------------
>
>                 Key: SPARK-5388
>                 URL: https://issues.apache.org/jira/browse/SPARK-5388
>             Project: Spark
>          Issue Type: Bug
>          Components: Spark Core
>    Affects Versions: 1.2.0
>            Reporter: Andrew Or
>            Assignee: Andrew Or
>            Priority: Blocker
>         Attachments: stable-spark-submit-in-standalone-mode-2-4-15.pdf
>
>
> The existing submission gateway in standalone mode is not compatible across 
> Spark versions. If you have a newer version of Spark submitting to an older 
> version of the standalone Master, it is currently not guaranteed to work. The 
> goal is to provide a stable REST interface to replace this channel.
> For more detail, please see the most recent design doc attached.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: issues-unsubscr...@spark.apache.org
For additional commands, e-mail: issues-h...@spark.apache.org

Reply via email to