[ 
https://issues.apache.org/jira/browse/SPARK-5894?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Xiangrui Meng updated SPARK-5894:
---------------------------------
    Assignee: Xusen Yin

> Add PolynomialMapper
> --------------------
>
>                 Key: SPARK-5894
>                 URL: https://issues.apache.org/jira/browse/SPARK-5894
>             Project: Spark
>          Issue Type: Sub-task
>          Components: ML
>            Reporter: Xiangrui Meng
>            Assignee: Xusen Yin
>
> `PolynomialMapper` takes a vector column and outputs a vector column with 
> polynomial feature mapping.
> {code}
> val poly = new PolynomialMapper()
>   .setInputCol("features")
>   .setDegree(2)
>   .setOutputCols("polyFeatures")
> {code}
> It should handle the output feature names properly. Maybe we can make a 
> better name for it instead of calling it `PolynomialMapper`.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: issues-unsubscr...@spark.apache.org
For additional commands, e-mail: issues-h...@spark.apache.org

Reply via email to